T310 无法启动操作系统

PowerEdge服务器

PowerEdge服务器
加入对PowerEdge服务器和系统管理实践的讨论

T310 无法启动操作系统

这个问题已经回答Eahua (Dell Technology)

T310  提示过一段时间主板电池没电,一天停电后,开机界面没有显示进入raiid的提示信息。是否是因为主板电池没电导致raid的信息丢失而无法进入系统?有什么办法可以恢复吗?谢谢各位大神赐教~~~

验证的回答
  • 如果还是这样!~服务器上除了这四个硬盘做了两个Raid1之外,有没有自行在主板SATA接口上接了硬盘去做系统盘,通常不会有人这么做。先排除一下!~

    如果没有,那就真的可能是引导文件损坏的问题了,数据重要的话,使用下载以下链接的ISO引导盘,刻录到光盘或U盘中引导启动,进入引导盘的Centos PE后,可以打开里面原有的硬盘里面分区备份走数据后重装吧!!!

    linux.dell.com/.../OMSA71-CentOS6-x86_64-LiveDVD.iso

所有回复
  • Hello!

    主板电池没现不会导致Raid信息丢失,即使是阵列卡有带缓存电池,没电的情况也不会,估计是不是所有硬盘离线了,状态是Foreign,阵列卡是什么型号吗? 

  • 是不是 回写的提示啊,有的时候,跳过 回写也可以启动的啊,具体要看显示的是什么内容

  • 沒有提示說硬盘离线,阵列卡型号不记得了。

    按F1后

  • 提示不是告诉没有引导盘吗?“No boot device available“。

    重新开机看看没有阵列卡的信息显示?不清楚的话,就开机每个画面都拍个照~~

  • 有显示SATA Port E device not found  ,有如下画面。谢谢您的指导。

  • 请忽略SATA Port E的错误信息,这是应该是BIOS把这个SATA E的口 Enable了,但是没有接设备,显示错误信息是正常的。

    你的问题应该是在这张型号为PERC6/I 的阵列卡上面,重启服务器在这个画面的时候,按键盘Ctrl+R 进去阵列卡的BIOS里面,把里面显示的内容截图看 看,进去后按键盘Ctrl+N是下一个画面,Ctrl+P是上一个画面,应该有四版。

  • 按 ctrl+R  进入阵列卡界面有三个界面如下图:

  • 看上面三个截图,你的阵列目前是正常的哦!!!

    目前服务器配置了两组Raid1。另服务器问下当初系统安装的同事,在Virtual Disk0 上还是1上,如果是1上,在第三张图哪里的的Select Bootable VD中的VD 0 953344 MB哪里按回车选择VD1,但通常是安装在VD0上。

    以上步骤先不做,我们先去主板的BIOS中先检查启动的顺序及设备,开机按F2进入BIOS,然后参考下图中的两个选项里面的设置截图给我看看。

  • 阵列正常就太好了!

  • 把第一张图里的 Port E 改为 Off,消除启动的时候误报!

    另把第二张图里的Boot Sequence 回车进去截图看看。

  • 看看按键盘上的+号把第二个 移到第一去,然后退出保存,看看能不能启动操作系统。

    如果不行,重启服务器的时候按键盘F11 BIOS Boots Manager

    然后选择Hard drive C看看。

    如果仍然不行,我们再去上面我说的,把Select Bootable哪里改为VD1,退出保存重启看看。

  • 把第二项移到第一位去后,保存重启主机还是一样的界面无法进入系统。

  • 把第二项移到第一位去后,保存重启主机还是进入不了系统。。。Crying

  • 大神,在吗?请问还有其他需要排查的地方吗?试过了您的方法还是一样Crying