感谢来自DELL售后高级技术工程师Jack_Yang的分享

DHCP 服务是网络交换机重要服务,现在很多用户需要在交换机上配置 DHCP 服务,这样可以节省一台服务器的开销,而且管理也比较方便。

以下是关于 DHCP service 和 DHCP relay 配置实例,大家可以参考学习。

1、网络拓扑图如下:S55-4-1DHCP reply ,S55-4-2 做DHCP server

   两台交换机直接是通过 静态路由进行通讯。

clip_image002

2、Force10  S55 4-2  交换机配置如下:

F10-4-1-S55#show vlan

Codes: * - Default VLAN, G - GVRP VLANs, P - Primary, C - Community, I - Isolated

Q: U - Untagged, T - Tagged

   x - Dot1x untagged, X - Dot1x tagged

   G - GVRP tagged, M - Vlan-stack, H - VSN tagged

NUM    Status    Description                     Q Ports

*   1      Inactive

    4      Active                                    U Gi 0/0

    40     Active                                    U Gi 0/1

F10-4-1-S55#show interfaces vlan 4

Vlan 4 is up, line protocol is up

Address is 00:01:e8:8a:ff:e0, Current address is 00:01:e8:8a:ff:e0

Interface index is 1107787780

Internet address is 192.168.4.1/24

F10-4-1-S55#show interfaces vlan 40

Vlan 40 is up, line protocol is up

Address is 00:01:e8:8a:ff:e0, Current address is 00:01:e8:8a:ff:e0

Interface index is 1107787816

Internet address is 192.168.40.1/24

F10-4-1-S55(conf)#interface vlan 4

F10-4-1-S55(conf-if-vl-4)#show config

!

interface Vlan 4

ip address 192.168.4.1/24

untagged GigabitEthernet 0/0

ip helper-address 192.168.55.2                      ip helper 指定DHCP server 地址

no shutdown

F10-4-1-S55(conf)#interface vlan 40

F10-4-1-S55(conf-if-vl-40)#show config

!

interface Vlan 40

ip address 192.168.40.1/24

untagged GigabitEthernet 0/1

ip helper-address 192.168.55.2                     ip helper 指定DHCP server 地址

no shutdown

3、Force10  S55 4-2  交换机配置如下:

F10-4-2-S55(config-dhcp)#show config

!

ip dhcp server

!

pool 192.168.140.0 定义DHCP 池 命名为 192.168.140.0 ,这个可以随意定义,或者定义为Vlan 140

  network 192.168.140.0/24

  default-router 192.168.140.1

!

pool 192.168.4.0 定义DHCP 池 命名为 192.168.140.0 ,这个可以随意定义,或者定义为Vlan 4

  network 192.168.4.0/24

  default-router 192.168.4.1

!

pool 192.168.40.0

  network 192.168.40.0/24

no disable 最重要一条, DHCP server 要 no disable ,就是要enable 起来

F10-4-2-S55(conf-if-gi-0/0)#show config

!

interface GigabitEthernet 0/0                            连接Client 4-3  通过DHCP 获得ip address 192.168.140.254

ip address 192.168.140.1/24

ip helper-address 192.168.55.2                         指定 DHCP 服务器 为 192.168.55.2

no shutdown

F10-4-2-S55(conf-if-gi-0/0)#

4、交换机配置完毕,进行互联测试:

clip_image003

Vlan 4 下连接的client 4-1 通过DHCP 获得 地址 192.168.4.254

clip_image004

Vlan 40  下连接的client  4-2  通过DHCP 获得地址 192.168.40.254

clip_image005

Client  4-3  通过DHCP 获得地址 192.168.140.254

clip_image006

通过 Client  4-2   地址是 192.168.4.254  ,都可以正常Ping 通 client 4- 1 ,client 4-3 机器

clip_image007